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Note to the Author

[This document is a template of a Data Conversion Plan document for a project. Data conversion is an extremely dynamic process. This document can not be detailed enough to address all the potential variables one must consider when performing a data conversion; therefore the final determination of items addressed by this plan are left to the discretion of the project manager and the integrated project team. The template includes instructions to the author, boilerplate text, and fields that should be replaced with the values specific to the project.

· Blue italicized text enclosed in square brackets ([text]) provides instructions to the document author, or describes the intent, assumptions and context for content included in this document.

· Blue italicized text enclosed in angle brackets (<text>) indicates a field that should be replaced with information specific to a particular project.

· Text and tables in black are provided as boilerplate examples of wording and formats that may be used or modified as appropriate to a specific project.  These are offered only as suggestions to assist in developing project documents; they are not mandatory formats.

When using this template for your project document, it is recommended that you follow these steps:

1. Replace all text enclosed in angle brackets (i.e., <Project Name>) with the correct field values. These angle brackets appear in both the body of the document and in headers and footers.  To customize fields in Microsoft Word (which display a gray background when selected):

a. Select File>Properties>Summary and fill in the Title field with the Document Name and the Subject field with the Project Name.  

b. Select File>Properties>Custom and fill in the Last Modified, Status, and Version fields with the appropriate information for this document. 

c. After you click OK to close the dialog box, update the fields throughout the document with these values by selecting Edit>Select All (or Ctrl-A) and pressing F9.  Or you can update an individual field by clicking on it and pressing F9. This must be done separately for Headers and Footers.

2. Modify boilerplate text as appropriate to the specific project. 

3. To add any new sections to the document, ensure that the appropriate header and body text styles are maintained.  Styles used for the Section Headings are Heading 1, Heading 2 and Heading 3.  Style used for boilerplate text is Body Text.

4. To update the Table of Contents, right-click and select “Update field” and choose the option- “Update entire table”

5. Before submission of the first draft of this document, delete this “Notes to the Author” page and all instructions to the author, which appear throughout the document as blue italicized text enclosed in square brackets.]
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Introduction
1.1 Purpose of Data Conversion Plan
[Describe the purpose of the Data Conversion Plan Provide full identifying information for the automated system, application, or situation for which the Data Conversion Plan applies, including as applicable, identifications number(s), title(s)/name(s), abbreviation(s)/acronym(s), part number(s), version number(s), and release number(s).  Summarize the purpose of the document, the scope of activities that resulted in its development, the intended audience for the document, and expected evolution of the document.  Also describe any security or privacy considerations associated with use of the Data Conversion Plan.]
This Data Conversion Plan describes the strategy, preparation, and specifications for converting data from <source system(s) to the <target system(s) or within an existing system>.  This plan describes the overall approach, assumptions, and processes that will be used in the data conversion.  It includes an inventory and cross reference of source and target data elements, schema, metadata and all self-describing files; process for data extraction, transformation and loading for each data source; tools needed to execute the conversion; and strategy for data quality assurance and control.

The intended audience of the <Project Name> Data Conversion Plan is the Business Sponsor and the Integrated Project Team.
1.2 Data Conversion Objectives

[Describe objectives of the Data Conversion Plan.]

· [Insert description of the first objective.]

· [Insert description of the second objective.]

· [Add additional bullets as necessary]

1.3 Assumptions

This section identifies the statements believed to be true for the Data Conversion Plan. 

[Describe any assumptions or dependencies regarding the data conversion effort. These may concern such issues as: related software or hardware, operating systems, end-user characteristics, and/or the data that must be available for the conversion.]

· [Insert description of the first assumption.]

· [Insert description of the second assumption.
· [Add additional bullets as necessary]

1.4 Constraints

This section identifies any limitation that must be taken into consideration prior to the Data Conversion from the old to the new product or IT system.
[Describe any limitations or constraints that have a significant impact on the data conversion effort.  Such constraints may be imposed by any of the following (the list is not exhaustive):

a) Hardware or software environment

b) End-user environment (e.g., user work and delivery schedules, timeframes for reports, etc.)

c) Availability of resources 

d) Interoperability requirements (e.g., the order that data is processed by each system involved in the conversion)

e) Interface/protocol requirements

f) Data repository and distribution requirements (e.g., volume considerations, such as the size of the database and amount of data to be converted; the number of reads and the time required for conversions)

g) Referential data integrity

h) Time allowed to complete the conversion process
i) Security Requirements]

· [Insert description of the first constraint.]

· [Insert description of the second constraint.]
· [Add additional bullets as necessary]
1.5 Risks
[Describe any risks associated with the data conversion and proposed mitigation strategies.  Include any risks that could affect conversion feasibility, technical performance of the converted system, the conversion schedule, costs, backup and recovery procedures, etc.]

· [Insert description of the first risk.]

· [Insert description of the second risk.]
· [Add additional bullets as necessary]
2 DATA CONVERSION STRATEGY
2.1 Conversion Scope
[Provide a rationale for the conversion and a general description of the boundaries of the data conversion effort.  This may include, but not be limited to, specific system functions affected and functions/data not affected/converted.  Provide a high-level mapping of the data and data types to be converted or migrated to the new system (e.g., the amount, type, and quality of the data; the original and target sources and formats; and any cross-reference complexities.)]

2.2 Conversion Approach
[Describe the approach that will be used to extract, transform/cleanse and load data from the source to target destinations during the conversion/migration process.  The following should be considered and addressed in this section and/or appropriate subsections, if applicable:

· Identify if the conversion process will be implemented in phases or stages, and if so, identify which components will undergo conversion in each phase. 

· Identify what data related to specific business processes will be converted first. 

· Describe any automated data conversion tools that will be used (e.g., Extract, Transform, and Load (ETL) tools).

· Identify and describe any part of the conversion process that will be performed manually.

· Identify and describe any custom-developed conversion programs that will be needed, and associated performance tuning.

· Identify criteria for a Go/No-Go decision.

· Identify staffing approach.

· Identify if parallel runs of the old and new systems will be necessary during the conversion process, or if there will be a one-time cut-over to the new system.

· Identify whether data availability and use should be limited during the conversion process.

· Describe security and privacy controls required for the conversion process.

· Describe the disposition of obsolete or unused data that is not converted
· Identify the retention policy for the data that has been converted in case of fall-back and have to rerun the conversion process.

· Consider NARA retention policies...]
2.3 Roles and Responsibilities
[List all stakeholders and document their roles and responsibilities in the conversion process.]

2.4 Conversion Schedule
[Provide a schedule of conversion activities to be accomplished in accordance with this Data Conversion Plan.  Show the required tasks in chronological order, with beginning and ending dates of each task, the key person(s) responsible for the task, dependencies, and milestones.  If appropriate, tables and/or graphics may be used to present the schedule.  Ensure that this information is appropriately integrated into the overall project schedule.  The schedule should be as comprehensive as possible; however, the schedule may be revised as needed at later points in the lifecycle. Rather than providing this schedule in the table below, the schedule may be added as an Appendix and may be developed in a project management tool.]

Table 1 Conversion Schedule

	Task  #
	Task Description
	Begin Date
	End Date
	Key Person(s) Responsible
	Dependencies
	Milestone



	<task #>
	<task description>
	<mm/dd/yy>
	<mm/dd/yy>
	<name(s)>
	<task  #(s)>
	<Yes/No>

	
	
	
	
	
	
	

	
	
	
	
	
	
	


2.5 Data Quality Assurance and Control
[Identify the types of data quality problems that may occur, including but not limited to the following considerations:

· data type redefinitions (e.g., alphas in dates and numbers, embedded information in codes and intelligent keys, implied content); 

· garbled content (e.g., multiple uses for a single field, freeform text values, corrupted data, un-initialized data);

· invalid record relationships (e.g., broken chains in set relationships, orphan records (on natural key), mismatched keys (set vs. natural key)); 

· invalid content (e.g., values out of defined range, code fields not on a valid list of values or lookup table, blank fields (optionality), inconsistent use of defaults);

· context changes (e.g., import of external data, historic changes to operational parameters (system upgrades), synchronization timing of duplicated denormalized data); and 

· behavior issues (e.g., variations in actual data from planned constraints of size, data type, validation rules, and relationships). 

Describe the strategy to be used to ensure data quality before and after all data conversions.    Also describe the approach to data scrubbing and quality assessment of data before they are moved to the new or converted system.  Describe the manual and/or automated controls and methods to be used to validate the conversion and to ensure that all data intended for conversion have been converted.  Describe the process for data error detection and correction, and the process for resolving anomalies.]

3 DATA CONVERSION PREPARATION
3.1 Prerequisites
[Describe all preparatory and/or initiation processes that must be completed prior to data conversion.  Describe specific data preparation requirements.  If the data will be transported from the original system, provide a detailed description of the data handling, conversion, and loading procedures.  If the data will be transported using machine-readable media, describe the characteristics of that media.  Identify any support materials needed for the conversion process.]
3.2 Backup Strategy
[Describe how the source and target data baselines will be created and managed prior to any manipulation or migration.  Also describe backups that may occur incrementally while stepping through the process of preparing, moving, and manipulating the data during conversion.]

3.3 Restore Process
[Describe the process to restore the source data if the need to revert to a previous back-up is identified at any point during the conversion process.]
4 DATA CONVERSION SPECIFICATIONS
[Provide a cross reference of the input (source) data that is to be converted to the resultant output (target) data.  Also identify if any of the data are derived from other data.  Provide transformation/cleansing rules for each data element and any other additional considerations.    Transformation and cleansing rules may include, but not limited to, the following:

· Translation of literal value(s) to literal value(s)

· Default null to literal value

· Empty field processing (i.e., null to space or space to null)

· Formulas (i.e., simple equations and mathematical expressions)]

Table 2 Data Conversion Specifications
	Source
	Source Data Element
	Destination
	Target Data Element
	Transformation/ Cleansing Rules
	Notes

	<Source Location (e.g., System/File/ Database Table, etc.>
	<Source Data Element Identifier (e.g., SSN)>
	<Target Location (e.g., Database Table)>
	<Target Data Element Identifier (e.g., Member ID)>
	<Describe data transformation that is to occur, including any data cleansing.>
	<Describe any timing constraints or anything unique about the conversion.>



	
	
	
	
	
	

	
	
	
	
	
	


Appendix A:  DATA CONVERSION PLAN approval

The undersigned acknowledge they have reviewed the Data Conversion Plan and authorize and fund the <Project Name> project.  The undersigned herby give the project manager the authority to apply the approved level of organizational resources to project activities. Changes to this Data Conversion Plan will be coordinated with and approved by the undersigned or their designated representatives.

[List the individuals whose signatures are desired.  Examples of such individuals are Business Sponsor and Project Manager.  Add additional lines for signature as necessary. Although signatures are desired, they are not always required to move forward with the practices outlined within this document.]

	Signature:
	
	Date:
	

	Print Name:
	
	
	

	Title:
	
	
	

	Role:
	
	
	


	Signature:
	
	Date:
	

	Print Name:
	
	
	

	Title:
	
	
	

	Role:
	
	
	


	Signature:
	
	Date:
	

	Print Name:
	
	
	

	Title:
	
	
	

	Role:
	
	
	


APPENDIX B: REFERENCES

[Insert the name, version number, description, and physical location of any documents referenced in this document.  Add rows to the table as necessary.] 

The following table summarizes the documents referenced in this document.

	Document Name and Version
	Description
	Location

	<Document Name and Version Number>
	[Provide description of the document]
	<URL or Network path where document is located>


APPENDIX C: KEY TERMS

[Insert terms and definitions used in this document.  Add rows to the table as necessary. Follow the link below to for definitions of project management terms and acronyms used in this and other documents.]

The following table provides definitions for terms relevant to this document.

	Term
	Definition

	[Insert Term]
	[Provide definition of the term used in this document.]

	[Insert Term]
	[Provide definition of the term used in this document.]

	[Insert Term]
	[Provide definition of the term used in this document.]
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[Insert appropriate Disclaimer(s)]
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